Jul 11 2016

Windows 8.1/ Windows 10 / Server 2012 R2 Gruppenrichtlinien – Anmeldeskripte werden nicht oder nur stark verzögert ausgeführt!

Seitdem ich in meiner Testumgebung einige Clients von Windows 7 auf Windows 10 upgegraded bzw. ausgewechselt habe, ist mir aufgefallen, dass mein Anmeldeskript (Logon Skript) nicht mehr ausgeführt wird!
Zuerst dachte ich dass ich evtl. einen Fehler in den Gruppenrichtlinien habe, oder es evtl. an meiner Virtuellen Umgebung liegt!

Aber nach kurzer Recherche im Internet, stellte ich fest dass dies kein „Fehler“ ist, sondern eher ein „Feature“ !

Das ganze ist nämlich bereits ab Windows 8.1 so, nur ist mir dies nie aufgefallen, da ich bis dahin immer Windows 7 als Virtuelle Clients zum testen & üben verwendet habe!

Aber was genau ist das „Problem“ bzw. die Ursache?

Ursache:

Es ist eine neue Einstellung, welche ab Windows 8.1 standardmäßig in den Gruppenrichtlinien aktiviert ist!
Diese sorgt dafür, dass Anmeldeskripte (Logon Skripte) welche über Gruppenrichtlinien verteilt werden erst nach standardmäßig 5 Minuten nachdem Login des Benutzers ausgeführt werden!
Doch nicht immer möchte man dies, bzw. ist dass auch sinnvoll!
Gerade wenn man z.b.:Drucker verbindet, bei E-Mail Signaturen etc…. ist es von Vorteil wenn so wie „früher“ die Anmeldeskripte sofort nachdem Login des Benutzers ausgeführt bzw. angewendet werden!
Laut Microsoft soll diese neue Standardkonfiguration in den Gruppenrichtlinien für einen schnelleren Anmeldevorgang sorgen, also das Anmelden „beschleunigen“ …

Hier kurz die „Lösung“ damit die Anmeldeskripte wieder sofort beim Login ausgeführt werden:


Gruppenrichtlinien Editor öffnen und je nach Wunsch folgende Konfiguration setzten:

Ausführen der Anmeldeskripte des Benutzers ohne Zeitverzögerung:
Computerkonfiguration\Administrative Vorlagen\system\gruppenrichtlinie: Logon-Skript Verzögerung Konfigurieren == > deaktiviert

ODER:

Auf ==> aktiviert setzten und bei der Zeit „0“ (NULL) eintragen!

Ändern der Zeitverzögerung für das Ausführen der Anmeldeskripte:
Computerkonfiguration\Administrative Vorlagen\system\gruppenrichtlinie: Logon-Skript Verzögerung Konfigurieren == > aktiviert

Danach sollte alles wieder „wie gewohnt“ funktionieren!  😉

Quelle:https://support.microsoft.com/de-at/kb/2895815

Permanentlink zu diesem Beitrag: http://blog.adminweb.at/windows-8-1-windows-10-server-2012-r2-gruppenrichtlinien-anmeldeskripte-werden-nicht-oder-nur-stark-verzoegert-ausgefuehrt/

2 Kommentare

  1. Ich weiß nicht ob das wirklich ein Feature ist. Für mich ist das eher eine weitere Fehlerquelle und ich kann nicht ganz nachvollziehen, warum Microsoft das geändert hat.

    1. Hallo Michael!

      Ja der Meinung bin ich auch, darum habe ich das ganze auch unter Anführungszeichen geschrieben =)

      LG
      Daniel

Schreibe einen Kommentar

Your email address will not be published.